Не устраняется сообщение об уязвимости флеш-плеера, что делать?

При открытии сайта с видео контентом выводиться сообщение "Этот плагин является уязвимым и должен быть обновлён". Проверка наличия обновлений ведет к странице которая указывает на плагин "Shockwave Flash 15.0 r0" и состояние "уязвимый 15.0.0.189". Далее кнопка "Обновить сейчас" открывает страницу с заголовком "Adobe Security Bulletin". Там внизу ссылка "Flash Player Download Center" но обновление через неё не помогает устранить предупреждение.

Дополнено (1). Спасибо ВСЕМ!

НЕОЖИДАННО, ответ нашел сам:
Открыл официальный сайт Adobe, а там через поиск ввёл "Shockwave Flash", очевидно это не тот же самый "Adobe Flash Player" а отдельный продукт. Короче, через поиск попал на страницу этого самого - Shockwave Flash, и обновил. Вот и всё. Раздражающее сообщение об уязвимости исчез. А в дополнениях к Мозилле появился - Shockwave Flash 16 (уже новая версия).
Но почему обновление из дополнений или из самого окна видео предлагал обновить Adobe Flash Player (а не Shockwave Flash) все-таки не понял.
Еще раз спасибо всем кто откликнулся.

//При открытии сайта с видео контентом выводиться сообщение "Этот плагин является уязвимым и должен быть обновлён".// ---пожалуйста, никода не нажимаем Обновить итд, для обновл Панель управл---Проги и компоненты--AdobeFlashPlayer---Удалить далее идем сюда adobe.com и Устанавливаем (без хвостов --маккофе, макводка итп). Что за браузер?

Попробуй установить через инструменты-дополнения-получить дополнения, у меня получилось…

Прямые ссылки, без веб-установщика - 1-я плагин для браузера, 2-я плеер
http://fpdownload.adobe.com/get/flashplayer/current/licensing/win/install_flash_player_16_plugin.exe
http://fpdownload.adobe.com/get/flashplayer/current/licensing/win/install_flash_player_16_active_x.exe