Не отображается флеш в опере через XSL

Я в php-файле динамически формирую xml и подключаю к нему xsl-шаблон. В xsl-файле формирую отображение, а именно вывожу флеш баннер. Во всех браузерах работает нормально, но в Опере баннер отображаться не хочет. Причем, если я вставляю этот флеш-баннер в обычную html-страницу, то он отображается. То есть проблемы с флеш-плеером нет. Никто не знает, в чем проблема может быть?

Вот код php-файла(его я и запускаю в браузере):
<?php header('Content-Type: text/xml');?>
<?php
$xml_string = '<?xml version="1.0" encoding="utf-8"?>'."\n";
$xml_string.= '<?xml-stylesheet type="text/xsl" href="test.xsl" ?>'."\n";
$xml_string.= '<template>'."\n";
$xml_string.= '</template>'."\n";
echo $xml_string;
?>

Файл test.xsl:
<xsl:stylesheet version="2.0"
xmlns: xsl="http://www.w3.org/1999/XSL/Transform"
xmlns: xs="http://www.w3c.org/2001/XMLSchema">

<xsl:output method="html"
           indent="yes"
           version="1.0" />
           
<xsl:template match="template">

<html xmlns="http://www.w3.org/1999/xhtml">
<head>
  </head>
<body >
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8, 0, 0, 0" width="728" height="90">

<param name="movie" value="img/banners/mits.swf" />
<param name="quality" value="high" />
<param name="flashvars" />
<param name="type" value="application/x-shockwave-flash" />
<embed src="img/banners/mits.swf" width="728" height="90" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" autostart="true" >
</embed>
</object>
</body></html>
</xsl:template>

</xsl:stylesheet>

Потому что опера не понимает XSL

Вы заблуждаетесь. Опера очень даже "понимает" XSL. Просто кое-что она пока что не поддерживает. Почти желаемого эффекта добился с помощью обычной перегрузки содержимого. <object> запихнул в <div> и после его загрузки тупо написал
document.getElementById('id').innerHTML = document.getElementById('id').innerHTML.
Вот такое вот решение.
Только появилась новая проблема - опера до версии 9.5 не поддерживает пердачу данных из формы через xml+xsl. Может кто-то уже сталкивался с таким?