Flash banner не отображается в Хроме и отображается в ИЕ в чем ошибка?

Разместил на страничке флэшку и она не загружается в Хроме, но при этом нормально работает в ИЕ. Не могу понять почему так происходит. Может ли это быть связано с весом почти 0.5Мб?

Дополнено (1). да установлен.
Вот код вставки:
   <div style="width:570px; height:207px; margin: 15px 0 0 0px;">
     <object width="570" height="207" align="middle" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8, 0, 0, 0">
           <param value="sameDomain" name="allowScriptAccess">
           <param value="false" name="allowFullScreen">
           <param value="opaque" name="wmode">
           <param value="550х200_healthyWindows.swf" name="movie">
           <param value="high" name="quality">
           <param value="#ffffff" name="bgcolor">
           <param value="showall" name="scale">
         <embed width="570" height="207" align="middle" scale="showall" pluginspage="http://www.adobe.com/go/getflashplayer" type="application/x-shockwave-flash" allowfullscreen="false" allowscriptaccess="sameDomain" wmode="opaque" name="okna" bgcolor="#ffffff" quality="high" src="550х200_healthyWindows.swf" />
       </object>
 
        <a style="display: block; width: 570px; margin: -207px 0 0; background: url(/images/blank.gif); position: relative; height: 207px;" href="#call" title="call" class="p_call" id="banner"></a>
     </div>

Если я в параметре src указываю другую swf то она отображается во всех браузерах. Что может быть не так?
Как я уже писал нужный мне банер отображается в ИЕ, но не отображается в опере, фф и хроме. Что-то не так с тэгом embed?

У тебя flash plaer установлен(это самая примитивная проблема)